Welcome to the CodeSmith Community!

CodeSmith Generator 5.3 Released, Thanksgiving Sale 25% Off

CodeSmith Official

CodeSmith Official Blogs

CodeSmith Generator 5.3 Released, Thanksgiving Sale 25% Off

Rate This
  • Comments 3

CodeSmith Generator 5.3 Released

The new CodeSmith Tools look has finally arrived for the CodeSmith Generator! Sporting a new name, new splash screen, new logos, and new colors, CodeSmith Generator has never looked better.

Notable features include: 

  • Improved Visual Studio 2010 Support
  • New Icons, Logos, and Branding
  • Updated Connection String Designers
  • Updated PLINQO and CSLA Templates
  • Fixed CSP Generate On Build Issues

Download CodeSmith Generator 5.3 Now!
For more details please see the complete change log.

Thanksgiving Sale - 25% Off CodeSmith Generator

Thanksgiving is a holiday to express thankfulness, gratitude, and appreciation to family and friends. In the spirit of the holiday CodeSmith Tools wants to thank you for another great year, and a great start to the new decade.

To express our gratitude, we are running a two week CodeSmith Generator special, starting today (11/16/2010) and ending just after Black Friday (11/28/2010):

25% Off CodeSmith Generator Purchases

Just use the coupon code THXGVN when you checkout, and have a happy holiday!

kick it on DotNetKicks.com

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment
  • * Please enter your name
  • * Please enter a comment
  • Post
  • You've been kicked (a good thing) - Trackback from DotNetKicks.com

  • Excellent sale!

    I am seriously considering taking advantage of it. However, I'd like to get some advice first.

    I have a personal licence for v5.1.5 which I cannot upgrade because it was a promo. I had used CS and the then version of plinqo to create a project in vs2008 which I am still developing/maintaining. I've done tests with subsequent versions of plinqo and codesmith, and here is what I've found:

    - later versions of plinqo don't work with my current version of codesmith

    - later versions of codesmith don't work with my current version of plinqo

    - using a later version of codesmith with the paired version of plinqo produces code that is incompatible with the old codebase and/or will take too long to convert/fix.

    Thus, I must keep my current version of codesmith and plinqo in order to ensure I'll be able to maintain my project now and in the near future. However, I wish to get the new versions of codesmith and plinqo, and integrate them into vs2010.

    I see that there is a manual install download for v5.3 so I'm wondering if it is possible to run that side-by-side, as it were, with v5.1.5. I can register 5.3 with vs2010 alone and only use vs2008 for older projects. Will this work?

  • Hello,

    Please see the following response located here(community.codesmithtools.com/.../44143.aspx) on this subject. Please let us know if you have any questions.

    Thanks

    -Blake Niemyjski

Page 1 of 1 (3 items)