Due to some issues with the installer, we have released another RC build for CodeSmith 3.2.

CodeSmith 3.2 is targeted to the .NET 2.0 platform.  If you want to use .NET 2.0 language features in your template code or you want integration with the VS.NET 2005 IDE, then you should try CodeSmith 3.2.  CodeSmith 3.2 does not contain any new features over CodeSmith 3.1 besides targetting .NET 2.0.  Also, CodeSmith 3.1 and 3.2 can be installed side-by-side.

CodeSmith 3.2 has been released now.